IPB

Здравствуйте, гость ( Вход | Регистрация )

> Правильно формулируйте вопросы - Вам быстрей ответят

Перед подачей запроса воспользуйтесь сервисом Поиск. Возможно Ваш вопрос уже был задан и доступно быстрое решение.

Для максимально быстрого решения проблемы обязательно укажите:
- адрес Вашего сайта + наименование хостинга (локальный/внешний)
- номер установленного релиза PHPSHOP CMS FREE (Указывается в админпанели. Пример PHPShop CMS Free (сборка 34501).
- подготовьте принтскрин Вашей проблемы (снимок рабочего стола в момент ошибки) и прикрепите принтскрин в теме.
- укажите наименование и/или номер ошибки.
- подробно опишите алгоритм Ваших действий при выполнении поставленной задачи

Доступная документация: http://wiki.phpshopcms.ru

Самые свежие релизы в центре загрузки: http://phpshop.ru/page/downloads.html

Голосуйте и добавляйте свои идеи для PHPSHOP CMS FREE: http://idea.phpshop.ru/

 
Ответить в данную темуНачать новую тему
> Strict Standards
max80dnepr
сообщение 31.1.2016, 0:08
Сообщение #1


Новичок
*

Группа: Пользователи
Сообщений: 2
Регистрация: 31.1.2016
Пользователь №: 4509
Версия CMS Free: 40002
Создано сайтов: 1



Подскажите пожалуйста как исправить
Strict Standards: Declaration of PHPShopInterface::setHeader() should be compatible with that of PHPShopGUI::setHeader() in C:\OpenServer\domains\dle\phpshop\class\admgui.class.php on line 1078
Перейти в начало страницы
 
+Цитировать сообщение
Dennion
сообщение 1.2.2016, 12:09
Сообщение #2


Администратор
***

Группа: Главные администраторы
Сообщений: 5910
Регистрация: 20.8.2009
Из: Москва
Пользователь №: 1
Версия CMS Free: 3.3



А версия какая CMS стоит?
Перейти в начало страницы
 
+Цитировать сообщение
max80dnepr
сообщение 1.2.2016, 21:01
Сообщение #3


Новичок
*

Группа: Пользователи
Сообщений: 2
Регистрация: 31.1.2016
Пользователь №: 4509
Версия CMS Free: 40002
Создано сайтов: 1



Цитата(Dennion @ 1.2.2016, 13:09) *
А версия какая CMS стоит?


Версия 40002

Вот это в Админке в шапке сверху пишет
Код
Strict Standards: Declaration of PHPShopInterface::setHeader() should be compatible with that of PHPShopGUI::setHeader() in C:\OpenServer\domains\dle\phpshop\class\admgui.class.php on line 1078



А вот это в 34406 пишет
Код
rict Standards: Non-static method PHPShopObj::loadClass() should not be called statically in C:\OpenServer\domains\localhost\PHPShop\phpshop\admpanel\admin.php on line 4

Strict Standards: Non-static method PHPShopObj::loadClass() should not be called statically in C:\OpenServer\domains\localhost\PHPShop\phpshop\admpanel\admin.php on line 5

Strict Standards: Non-static method PHPShopObj::loadClass() should not be called statically in C:\OpenServer\domains\localhost\PHPShop\phpshop\admpanel\admin.php on line 6

Strict Standards: Non-static method PHPShopObj::loadClass() should not be called statically in C:\OpenServer\domains\localhost\PHPShop\phpshop\admpanel\admin.php on line 7

Strict Standards: Declaration of PHPShopInterface::setHeader() should be compatible with that of PHPShopGUI::setHeader() in C:\OpenServer\domains\localhost\PHPShop\phpshop\class\admgui.class.php on line 966

Strict Standards: Declaration of PHPShopIcon::setTab() should be compatible with that of PHPShopGUI::setTab() in C:\OpenServer\domains\localhost\PHPShop\phpshop\class\admgui.class.php on line 1044

Strict Standards: Non-static method PHPShopObj::loadClass() should not be called statically in C:\OpenServer\domains\localhost\PHPShop\phpshop\admpanel\admin.php on line 8

Strict Standards: Non-static method PHPShopObj::loadClass() should not be called statically in C:\OpenServer\domains\localhost\PHPShop\phpshop\admpanel\admin.php on line 9
Перейти в начало страницы
 
+Цитировать сообщение
Dennion
сообщение 2.2.2016, 11:02
Сообщение #4


Администратор
***

Группа: Главные администраторы
Сообщений: 5910
Регистрация: 20.8.2009
Из: Москва
Пользователь №: 1
Версия CMS Free: 3.3



phpshop/class/base.class.php так стоит? Если что-то закоментировано, то поставьте как в примере.
Код
    /**
     *  Настройка уровня оповещения отладчика
     */
    function setPHPCoreReporting() {
        if (function_exists('error_reporting')) {
            error_reporting('E_ALL & ~E_NOTICE & ~E_DEPRECATED');
            if ($this->phpversion() and function_exists('ini_set')) {
                ini_set('allow_call_time_pass_reference', 1);
            }
        }
    }
Перейти в начало страницы
 
+Цитировать сообщение
ivgo
сообщение 29.3.2016, 20:02
Сообщение #5


Новичок
*

Группа: Пользователи
Сообщений: 1
Регистрация: 29.3.2016
Пользователь №: 4517
Версия CMS Free: 4.0.0.3
Создано сайтов: 1



Та же проблема !

Windows 7x32
Open Server 5.2.4
PHPShop CMS Free 4.0.0.3
в файле C:\OpenServer\domains\localhost\phpshop\class\base.class.php всё как было

Что ещё можете посоветовать? Спасибо

Разобрался, понизил версии:
PHP-5.3 -> PHP-5.2
и для удобства
Open Server 5.2.4 -> Open Server 5.2.3
Перейти в начало страницы
 
+Цитировать сообщение

Ответить в данную темуНачать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



RSS Текстовая версия Сейчас: 23.9.2019, 3:51